Project

General

Profile

Bug #2409

osd: pgs stuck in active

Added by Sage Weil almost 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
OSD
Target version:
% Done:

0%

Source:
Support
Tags:
Backport:
stable
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

congress has several pgs stuck in active, and objects counted as degraded. looks like we missed some corner case in the pg state logic.

History

#1 Updated by Anonymous almost 12 years ago

  • Backport set to stable

#2 Updated by Sage Weil over 11 years ago

saw this on burnupi. cranked up logging. hopefully we'll catch it again...

#3 Updated by Sage Weil over 11 years ago

  • Status changed from New to 7

oh, bother. this is wip-osd-peering not getting backported to dho branch. 17114f266a336b6edd7e98975d494fdd487eec20 (and 2 preceeding).

#4 Updated by Sage Weil over 11 years ago

  • Status changed from 7 to Resolved

Also available in: Atom PDF