Project

General

Profile

Bug #23909

snaps missing in mapper, should be: 188,18f,191,195,197,198,199,19d,19e,1a1,1a3 was r -2...repaired

Added by David Zafman over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
Start date:
04/27/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

New code for tracker #22881 in pull request https://github.com/ceph/ceph/pull/21546 no calls _scan_snaps() on each replica. During a trashing run this error is found:

"2018-04-26 17:25:17.998655 osd.7 osd.7 172.21.15.112:6800/35599 203 : cluster [ERR] osd.7 found snap mapper error on pg 3.1 oid 3:9f32f27c:::smithi17217362-19 oo...oo:1a3 snaps missing in mapper, should be: 188,18f,191,195,197,198,199,19d,19e,1a1,1a3 was r -2...repaired" in cluster log

http://pulpito.ceph.com/dzafman-2018-04-26_09:56:48-rados:thrash-wip-zafman-testing-distro-basic-smithi/2442050/


Related issues

Related to RADOS - Bug #22881: scrub interaction with HEAD boundaries and snapmapper repair is broken Resolved 02/01/2018
Related to RADOS - Bug #24045: Eviction still raced with scrub due to preemption Resolved 05/07/2018
Related to RADOS - Bug #40454: snap_mapper error, scrub gets r -2..repaired Verified 06/19/2019

History

#1 Updated by David Zafman over 1 year ago

  • Related to Bug #22881: scrub interaction with HEAD boundaries and snapmapper repair is broken added

#2 Updated by David Zafman over 1 year ago

  • Description updated (diff)

#3 Updated by David Zafman over 1 year ago

  • Priority changed from Normal to Urgent

#4 Updated by David Zafman over 1 year ago

  • Status changed from In Progress to Resolved

#5 Updated by Kefu Chai over 1 year ago

http://pulpito.ceph.com/kchai-2018-05-05_14:56:43-rados-wip-kefu-testing-2018-05-05-1912-distro-basic-smithi/

$ git br --contains 83861a5b75ddb98366f1ec106487b88703f25cf7 | grep wip-kefu-testing-2018-05-05-1912
* wip-kefu-testing-2018-05-05-1912

#6 Updated by David Zafman over 1 year ago

  • Status changed from Resolved to Need More Info

Does your branch include c20a95b0b9f4082dcebb339135683b91fe39ec0a? The change I made was needed to make that fix work properly.

#7 Updated by David Zafman over 1 year ago

Nevermind. I see you branch was still on ci repo.

$ git branch --contains c20a95b0b9f4082dcebb339135683b91fe39ec0a | grep wip-kefu-testing-2018-05-05-1912
wip-kefu-testing-2018-05-05-1912

#8 Updated by David Zafman over 1 year ago

  • Related to Bug #24045: Eviction still raced with scrub due to preemption added

#9 Updated by David Zafman over 1 year ago

  • Status changed from Need More Info to Resolved

#10 Updated by Sage Weil 2 months ago

  • Related to Bug #40454: snap_mapper error, scrub gets r -2..repaired added

Also available in: Atom PDF