Project

General

Profile

Bug #23876

[rbd-mirror] local tag predecessor mirror uuid is incorrectly replaced with remote

Added by Jason Dillaman about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

The tag predecessor mirror uuid that is retrieved from the remote peer is incorrectly converted to the remote mirror's uuid if it's set to the local mirror uuid. It should be set to the "LOCAL_MIRROR_UUID" constant. This causes sporadic issues in the base rbd-mirror teuthology test when the daemons are being trashed since the tag tids start to diverge.


Related issues

Copied to rbd - Backport #23902: luminous: [rbd-mirror] local tag predecessor mirror uuid is incorrectly replaced with remote Resolved
Copied to rbd - Backport #23903: jewel: [rbd-mirror] local tag predecessor mirror uuid is incorrectly replaced with remote Closed

History

#1 Updated by Jason Dillaman about 2 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Mykola Golub about 2 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #23902: luminous: [rbd-mirror] local tag predecessor mirror uuid is incorrectly replaced with remote added

#4 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #23903: jewel: [rbd-mirror] local tag predecessor mirror uuid is incorrectly replaced with remote added

#5 Updated by Jason Dillaman over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF