Project

General

Profile

Bug #23842

multisite: es sync null versioned object failed because of olh info

Added by Tianshan Qu over 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
04/25/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous mimic
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

if we disable bucket version, es sync null version object will get olh xattr info,
which are not string, es will decode that failed.


Related issues

Duplicated by rgw - Bug #23841: multisite: es sync instance not same between inc-sync and full-sync Duplicate 04/25/2018
Copied to rgw - Backport #37556: mimic: multisite: es sync null versioned object failed because of olh info Resolved
Copied to rgw - Backport #37557: luminous: multisite: es sync null versioned object failed because of olh info Resolved

History

#2 Updated by Abhishek Lekshmanan about 1 year ago

  • Status changed from New to Need Test

#3 Updated by Casey Bodley 10 months ago

  • Status changed from Need Test to Pending Backport
  • Backport set to luminous mimic

#4 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #37556: mimic: multisite: es sync null versioned object failed because of olh info added

#5 Updated by Nathan Cutler 10 months ago

  • Copied to Backport #37557: luminous: multisite: es sync null versioned object failed because of olh info added

#6 Updated by Nathan Cutler 7 months ago

  • Duplicated by Bug #23841: multisite: es sync instance not same between inc-sync and full-sync added

#7 Updated by Nathan Cutler 6 months ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF