Project

General

Profile

Bug #2351

osd: bad state machine event

Added by Sage Weil over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
OSD
Target version:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description


2012-04-26 02:09:27.903024 7f018a4a7700 -1 osd/PG.cc: In function 'PG::RecoveryState::Crashed::Crashed(boost::statechart::state<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine>::my_context)' thread 7f018a4a7700 time 2012-04-26 02:09:27.898549
osd/PG.cc: 3746: FAILED assert(0 == "we got a bad state machine event")

 ceph version 0.45-297-g81a248a (commit:81a248a11ca74eb6f03e4a12f83ef131668edec0)
 1: (PG::RecoveryState::Crashed::Crashed(boost::statechart::state<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::my_context)+0x105) [0x846275]
 2: /tmp/cephtest/binary/usr/local/bin/ceph-osd() [0x8768e6]
 3: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react_impl_non_empty::local_react_impl<boost::mpl::list2<boost::statechart::custom_reaction<PG::RecoveryState::AdvMap>, boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))> >, boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0> >(boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>&, boost::statechart::event_base const&, void const*)+0x17e) [0x88e2de]
 4: (boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0x86) [0x88e446]
 5: (boost::statechart::simple_state<PG::RecoveryState::Primary, PG::RecoveryState::Started, PG::RecoveryState::Peering, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0xd8) [0x8938f8]
 6: (boost::statechart::simple_state<PG::RecoveryState::Peering, PG::RecoveryState::Primary, PG::RecoveryState::GetInfo, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0x7d) [0x891fcd]
 7: (boost::statechart::simple_state<PG::RecoveryState::GetLog, PG::RecoveryState::Peering, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0xd8) [0x88dcf8]
 8: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::process_queued_events()+0x17b) [0x5c22db]
 9: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::process_event(boost::statechart::event_base const&)+0x14c) [0x881c6c]
 10: (PG::RecoveryState::handle_notify(int, pg_info_t&, PG::RecoveryCtx*)+0x210) [0x842720]
 11: (OSD::handle_pg_notify(std::tr1::shared_ptr<OpRequest>)+0x6ae) [0x6466de]
 12: (OSD::dispatch_op(std::tr1::shared_ptr<OpRequest>)+0x1b7) [0x646db7]
 13: (OSD::_dispatch(Message*)+0x1de) [0x65404e]
 14: (OSD::ms_dispatch(Message*)+0x1e3) [0x654fd3]
 15: (SimpleMessenger::dispatch_entry()+0xc33) [0x748673]
 16: (SimpleMessenger::DispatchThread::entry()+0x15) [0x6f79a5]
 17: (Thread::_entry_func(void*)+0x12) [0x765d12]
 18: (()+0x7efc) [0x7f0198189efc]
 19: (clone()+0x6d) [0x7f01967ba89d]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

ubuntu@plana55:/tmp/cephtest$ less archive/log/osd.2.log 
ubuntu@plana55:/tmp/cephtest$ logout
Connection to plana55.front.sepia.ceph.com closed.
ubuntu@teuthology:/a/nightly_coverage_2012-04-26-a/139$ 

History

#1 Updated by Sage Weil over 8 years ago

i saw this on my dev copy, might be the same


2012-04-25 16:41:44.124505 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 7/7 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] handle_notify 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) from osd.1
2012-04-25 16:41:44.124572 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 7/7 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  got osd.1 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.124652 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] update_heartbeat_peers 0,1 unchanged
2012-04-25 16:41:44.124674 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] state<Started/Primary/Peering/GetInfo>:  last_epoch_started moved forward, rebuilding prior
2012-04-25 16:41:44.124695 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(20-20 []/[0])
2012-04-25 16:41:44.124712 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(19-19 []/[])
2012-04-25 16:41:44.124723 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(18-18 []/[0])
2012-04-25 16:41:44.124738 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(17-17 []/[])
2012-04-25 16:41:44.124749 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(16-16 [1]/[1])
2012-04-25 16:41:44.124763 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(15-15 []/[])
2012-04-25 16:41:44.124773 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(14-14 [0]/[0])
2012-04-25 16:41:44.124787 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(13-13 []/[])
2012-04-25 16:41:44.124798 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(12-12 [1]/[1])
2012-04-25 16:41:44.124812 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(11-11 [0]/[0,1])
2012-04-25 16:41:44.124824 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(10-10 []/[1])
2012-04-25 16:41:44.124837 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(8-9 [1,0]/[1,0] maybe_went_rw)
2012-04-25 16:41:44.124850 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior interval(6-7 [0]/[0] maybe_went_rw)
2012-04-25 16:41:44.124863 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  PriorSet: build_prior final: probe 0,1 down  blocked_by {}
2012-04-25 16:41:44.124878 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] up_thru 20 < same_since 21, must notify monitor
2012-04-25 16:41:44.124895 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] state<Started/Primary/Peering/GetInfo>:  have osd.1 info 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.124935 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] exit Started/Primary/Peering/GetInfo 0.820254 1 0.000436
2012-04-25 16:41:44.124970 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] enter Started/Primary/Peering/GetLog
2012-04-25 16:41:44.124994 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] calc_acting osd.0 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.125011 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] calc_acting osd.1 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.125026 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] calc_acting newest update on osd.0 with 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.125042 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] up[0](osd.1) selected as primary
2012-04-25 16:41:44.125052 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] calc_acting primary is osd.1 with 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.125075 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering]  osd.0 (stray) accepted 1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20)
2012-04-25 16:41:44.125094 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] choose_acting want [1,0] != acting [0,1], requesting pg_temp change
2012-04-25 16:41:44.125140 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] exit Started/Primary/Peering/GetLog 0.000172 0 0.000000
2012-04-25 16:41:44.125161 7f05b5d5c700 10 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] state<Started/Primary/Peering>: Leaving Peering
2012-04-25 16:41:44.125175 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped+peering] exit Started/Primary/Peering 0.820511 0 0.000000
2012-04-25 16:41:44.125200 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped] exit Started/Primary 0.820552 0 0.000000
2012-04-25 16:41:44.125221 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped] exit Started 0.820635 0 0.000000
2012-04-25 16:41:44.125246 7f05b5d5c700 20 osd.0 21 pg[1.6( v 7'3 (0'0,7'3] n=3 ec=1 les/c 9/9 21/21/20) [1]/[0,1] r=0 lpr=21 lcod 0'0 mlcod 0'0 remapped] enter Crashed
2012-04-25 16:41:44.149127 7f05b5d5c700 -1 osd/PG.cc: In function 'PG::RecoveryState::Crashed::Crashed(boost::statechart::state<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine>::my_context)' thread 7f05b5d5c700 time 2012-04-25 16:41:44.125268
osd/PG.cc: 3746: FAILED assert(0 == "we got a bad state machine event")

 ceph version 0.45-312-gc56c0db (commit:c56c0db369b3bdcab275f2bb6126d32865b0aa58)
 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x80) [0xcf9658]
 2: (PG::RecoveryState::Crashed::Crashed(boost::statechart::state<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::my_context)+0xa6) [0xdcd5c4]
 3: (boost::statechart::state<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::shallow_construct(boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>* const&, boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>&)+0x49) [0xe09c35]
 4: (boost::statechart::state<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::deep_construct(boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>* const&, boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>&)+0x28) [0xe0959b]
 5: (boost::statechart::detail::inner_constructor<boost::mpl::l_item<mpl_::long_<1l>, PG::RecoveryState::Crashed, boost::mpl::l_end>, boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator> >::construct(boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>* const&, boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>&)+0x23) [0xe08ede]
 6: (boost::statechart::detail::safe_reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::transit_impl<PG::RecoveryState::Crashed, PG::RecoveryState::RecoveryMachine, boost::statechart::detail::no_transition_function>(boost::statechart::detail::no_transition_function const&)+0x80) [0xe089ac]
 7: (boost::statechart::detail::safe_reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::transit<PG::RecoveryState::Crashed>()+0x27) [0xe0842b]
 8: (boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>::reactions<PG::RecoveryState::Started>::react_without_action(PG::RecoveryState::Started&)+0x23) [0xe08060]
 9: (boost::statechart::detail::reaction_dispatcher<boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>::reactions<PG::RecoveryState::Started>, PG::RecoveryState::Started, boost::statechart::event_base, boost::statechart::event_base, boost::statechart::detail::no_context<boost::statechart::event_base>, void const*>::without_action::react(PG::RecoveryState::Started&, boost::statechart::event_base const&)+0x27) [0xe07942]
 10: (boost::statechart::detail::reaction_dispatcher<boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>::reactions<PG::RecoveryState::Started>, PG::RecoveryState::Started, boost::statechart::event_base, boost::statechart::event_base, boost::statechart::detail::no_context<boost::statechart::event_base>, void const*>::base::react(PG::RecoveryState::Started&, boost::statechart::event_base const&, void const* const&)+0x2f) [0xe07443]
 11: (boost::statechart::detail::reaction_dispatcher<boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>::reactions<PG::RecoveryState::Started>, PG::RecoveryState::Started, boost::statechart::event_base, boost::statechart::event_base, boost::statechart::detail::no_context<boost::statechart::event_base>, void const*>::react(PG::RecoveryState::Started&, boost::statechart::event_base const&, void const* const&)+0x2d) [0xe06dac]
 12: (boost::statechart::detail::reaction_result boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>::react<PG::RecoveryState::Started, boost::statechart::event_base, void const*>(PG::RecoveryState::Started&, boost::statechart::event_base const&, void const* const&)+0x2b) [0xe066e5]
 13: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react_impl_non_empty::local_react_impl<boost::mpl::list1<boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))> >, boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0> >(boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>&, boost::statechart::event_base const&, void const*)+0x33) [0xe05e28]
 14: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react<boost::mpl::list1<boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))> > >(boost::statechart::event_base const&, void const*)+0x2b) [0xe05675]
 15: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react_impl_non_empty::local_react_impl<boost::mpl::list2<boost::statechart::custom_reaction<PG::RecoveryState::AdvMap>, boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))> >, boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0> >(boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>&, boost::statechart::event_base const&, void const*)+0x53) [0xe04d2d]
 16: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react<boost::mpl::list2<boost::statechart::custom_reaction<PG::RecoveryState::AdvMap>, boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))> > >(boost::statechart::event_base const&, void const*)+0x2b) [0xe040cb]
 17: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react_impl_non_empty::local_react_impl<boost::mpl::list<boost::statechart::custom_reaction<PG::RecoveryState::QueryState>, boost::statechart::custom_reaction<PG::RecoveryState::AdvMap>, boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0> >(boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>&, boost::statechart::event_base const&, void const*)+0x53) [0xe026fe]
 18: (boost::statechart::detail::reaction_result boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::local_react<boost::mpl::list<boost::statechart::custom_reaction<PG::RecoveryState::QueryState>, boost::statechart::custom_reaction<PG::RecoveryState::AdvMap>, boost::statechart::transition<boost::statechart::event_base, PG::RecoveryState::Crashed, boost::statechart::detail::no_context<boost::statechart::event_base>, &(boost::statechart::detail::no_context<boost::statechart::event_base>::no_function(boost::statechart::event_base const&))>, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na> >(boost::statechart::event_base const&, void const*)+0x2b) [0xe0077d]
 19: (boost::statechart::simple_state<PG::RecoveryState::Started, PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Start, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0x2b) [0xdfd76b]
 20: (boost::statechart::simple_state<PG::RecoveryState::Primary, PG::RecoveryState::Started, PG::RecoveryState::Peering, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0x5f) [0xdfd13f]
 21: (boost::statechart::simple_state<PG::RecoveryState::Peering, PG::RecoveryState::Primary, PG::RecoveryState::GetInfo, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0x5f) [0xdfccc9]
 22: (boost::statechart::simple_state<PG::RecoveryState::GetLog, PG::RecoveryState::Peering, boost::mpl::list<mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na, mpl_::na>, (boost::statechart::history_mode)0>::react_impl(boost::statechart::event_base const&, void const*)+0x5f) [0xdfc47d]
 23: (boost::statechart::detail::send_function<boost::statechart::detail::state_base<std::allocator<void>, boost::statechart::detail::rtti_policy>, boost::statechart::event_base, void const*>::operator()()+0x41) [0xb5ff59]
 24: (boost::statechart::detail::safe_reaction_result boost::statechart::null_exception_translator::operator()<boost::statechart::detail::send_function<boost::statechart::detail::state_base<std::allocator<void>, boost::statechart::detail::rtti_policy>, boost::statechart::event_base, void const*>, boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::exception_event_handler>(boost::statechart::detail::send_function<boost::statechart::detail::state_base<std::allocator<void>, boost::statechart::detail::rtti_policy>, boost::statechart::event_base, void const*>, boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::exception_event_handler)+0x2b) [0xb57f2d]
 25: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::send_event(boost::statechart::event_base const&)+0x148) [0xb3fb78]
 26: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::process_queued_events()+0x5f) [0xb2e205]
 27: (boost::statechart::state_machine<PG::RecoveryState::RecoveryMachine, PG::RecoveryState::Initial, std::allocator<void>, boost::statechart::null_exception_translator>::process_event(boost::statechart::event_base const&)+0x70) [0xde3ff4]
 28: (PG::RecoveryState::handle_notify(int, pg_info_t&, PG::RecoveryCtx*)+0x1a9) [0xdd990d]
 29: (PG::handle_notify(int, pg_info_t&, PG::RecoveryCtx*)+0x34) [0xbbc988]
 30: (OSD::handle_pg_notify(std::tr1::shared_ptr<OpRequest>)+0x5c0) [0xbaa2e6]
 31: (OSD::dispatch_op(std::tr1::shared_ptr<OpRequest>)+0xdc) [0xb98266]
 32: (OSD::_dispatch(Message*)+0x9f7) [0xb990a5]
 33: (OSD::ms_dispatch(Message*)+0x1c0) [0xb971e6]
 34: (Messenger::ms_deliver_dispatch(Message*)+0x8c) [0xce30a4]
 35: (SimpleMessenger::dispatch_entry()+0x7f7) [0xcc952f]
 36: (SimpleMessenger::DispatchThread::entry()+0x1c) [0xc85e98]
 37: (Thread::_entry_func(void*)+0x23) [0xcecd8d]
 38: (()+0x6b50) [0x7f05c3a32b50]
 39: (clone()+0x6d) [0x7f05c206690d]
 NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

#2 Updated by Sage Weil over 8 years ago

  • Status changed from 12 to Resolved

Also available in: Atom PDF