Project

General

Profile

Bug #2350

conf: can't set subsystem settings (debug levels, logging settings) via librados or libcephfs

Added by Josh Durgin over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
common
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

With the recent rework of the logging infrastructure, md_config_t::set_val() was not updated to take into account subsystem options. md_config_t::parse_option() and other functions can still set these values, since they were updated with special handling for the subsystem options.

This means that things like qemu/rbd can't use debugging without using a config file.

Associated revisions

Revision 4e2e8794 (diff)
Added by Sage Weil over 8 years ago

config: allow {get,set}_val on subsystem debug levels

This mimics the allows you to get and set subsystem debug levels via the
normal config access methods. Among other things, this allows librados
users to set debug levels.

Fixes: #2350
Signed-off-by: Sage Weil <>

History

#1 Updated by Sage Weil over 8 years ago

  • Status changed from New to 12
  • Priority changed from Normal to High
  • Target version set to v0.47

#3 Updated by Sage Weil over 8 years ago

  • Status changed from 12 to Resolved

Also available in: Atom PDF