Project

General

Profile

Support #23457

rbd mirror: entries_behind_master will not be zero after mirror over

Added by liuzhong chen about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
% Done:

0%

Tags:
Reviewed:
Affected Versions:
Pull request ID:

Description

I have two ceph-12.2.2 cluster. Rbd mirror deamon run on cluster two. poolclz/rbdclz on cluster one is primary image and non-primary on cluster two.
When I write data in to poolclz/rbdclz by using fio or rbd bench, rbd mirror will data to cluster.
I find the entries_behind_master can't decrease to zero by using command "rbd mirror image status poolclz/rbdclz". That mean mirror_position is some entries behind master_position.I think this is unacceptable.

rbdclz:
  global_id:   105d7a59-06c0-404d-878e-80dadba39c55
  state:       up+replaying
  description: replaying, master_position=[object_number=7, tag_tid=30, entry_tid=295], mirror_position=[object_number=7, tag_tid=30, entry_tid=287], entries_behind_master=8
  last_update: 2018-03-23 20:09:39


I analysis the log of rbd mirror and find it may return "false" in the method try_pop_front of src/journal/JournalPlayer.cc.But I can't find the log of the src/journal/.
So is this a bug of rbd mirror? And where is the log of src/journal/.

History

#1 Updated by Jason Dillaman about 3 years ago

  • Status changed from New to Closed

Duplicate of #23516

Also available in: Atom PDF