Project

General

Profile

Bug #23369

User suspend on slave zone but not sync this stats to master zone

Added by Tave liu over 1 year ago. Updated over 1 year ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Target version:
Start date:
03/15/2018
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:

Description

suspend user on slave zone, and the user's stats is still enable on master zone;

History

#1 Updated by Greg Farnum over 1 year ago

  • Project changed from Ceph to rgw

#2 Updated by Casey Bodley over 1 year ago

  • Status changed from New to Won't Fix

changes to metadata (users, buckets) made on secondary zones are not replicated, by design. see http://docs.ceph.com/docs/master/radosgw/multisite/#configure-secondary-zones:

You must execute metadata operations, such as user creation, on a host within the master zone.

#3 Updated by Tave liu over 1 year ago

Casey Bodley wrote:

changes to metadata (users, buckets) made on secondary zones are not replicated, by design. see http://docs.ceph.com/docs/master/radosgw/multisite/#configure-secondary-zones:

You must execute metadata operations, such as user creation, on a host within the master zone.

But I thought that even if execute metadata operations in slave, it should be called back to master to execute

Also available in: Atom PDF