Project

General

Profile

Bug #23330

mon command "mgr metadata $name" has inconsistent argument naming

Added by Jan Fajerski over 2 years ago. Updated over 2 years ago.

Status:
Pending Backport
Priority:
Normal
Assignee:
Category:
MgrMonitor
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When running the following mon command:

std::ostringstream oss;
auto c = new MetadataUpdate(daemon_state, key);
oss << "{\"prefix\": \"mgr metadata\", \"who\": \"" 
      << key.second << "\"}";
monc->start_mon_command({oss.str()}, {}, &c->outbl, &c->outs, c);

MetadataUpdate::finish tries to decode an object but receives an array with one element.


Related issues

Related to mgr - Bug #23286: mgr: ActivePyModules::list_servers_python() returns mgr with empty hostname Pending Backport 03/09/2018
Copied to mgr - Backport #23722: luminous: mon command "mgr metadata $name" has inconsistent argument naming Need More Info

History

#1 Updated by Jan Fajerski over 2 years ago

  • Subject changed from mon command "mgr metadata $name return json array (object expected) to mon command "mgr metadata $name" returns json array (object expected)

#2 Updated by John Spray over 2 years ago

  • Subject changed from mon command "mgr metadata $name" returns json array (object expected) to mon command "mgr metadata $name" has inconsistent argument naming
  • Status changed from New to Fix Under Review

This command was using `id` where all the other metadata commands were using `who`, so anyone passing `who` is getting the list.

https://github.com/ceph/ceph/pull/20866

#3 Updated by John Spray over 2 years ago

  • Category set to MgrMonitor
  • Assignee set to Jan Fajerski
  • Backport set to luminous

Marking for backport because will want to take it along with fix for 23286 when that's done

#4 Updated by John Spray over 2 years ago

  • Related to Bug #23286: mgr: ActivePyModules::list_servers_python() returns mgr with empty hostname added

#5 Updated by Sage Weil over 2 years ago

  • Status changed from Fix Under Review to Resolved

#6 Updated by Nathan Cutler over 2 years ago

  • Status changed from Resolved to Pending Backport

#7 Updated by Nathan Cutler over 2 years ago

  • Copied to Backport #23722: luminous: mon command "mgr metadata $name" has inconsistent argument naming added

#8 Updated by Nathan Cutler over 2 years ago

Preparing for backport on the assumption that Sage didn't mean to override #23330-3

Also available in: Atom PDF