Project

General

Profile

Bug #23296

Cache-tier forward mode hang in luminous

Added by Ting-Yi Lin over 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Objecter
Target version:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The cache-tier forward mode is hanging in luminous. It seems that the client is keep sending request to cache-tier's osd and the osd always replied redirect to client.

This can be reproduced by
1. Create cache-tier
2. Set cache mode to forward
3. Write data to the pool
No data will be written and all the requests are keep retrying.

History

#2 Updated by Kefu Chai over 3 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Ting-Yi Lin
  • Backport set to luminous

#3 Updated by Yuri Weinstein about 3 years ago

Ting-Yi Lin wrote:

Fixes: https://github.com/ceph/ceph/pull/20766

merged to luminous

#4 Updated by Nathan Cutler about 3 years ago

  • Status changed from Fix Under Review to Need More Info

Fix merged directly to luminous. Now need to clarify whether the issue is fixed in master. If it is, the backport should have been done as a cherry-pick. If it isn't, then we'll need to forward-port the luminous fix to master.

#5 Updated by Nathan Cutler about 3 years ago

  • Status changed from Need More Info to Fix Under Review

Luminous backport is done and merged.

Forward-port to master: https://github.com/ceph/ceph/pull/21275

#6 Updated by Kefu Chai about 3 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF