Project

General

Profile

Bug #23262

kclient: nofail option not supported

Added by Kenneth Waegeman over 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
nautilus,mimic,luminous
Regression:
No
Severity:
3 - minor
Reviewed:
ceph-qa-suite:
Component(FS):
kceph
Labels (FS):
Pull request ID:

Description

I get an invalid argument when trying to mount ceph with nofail option
mon01,mon02,mon03:/ /mnt/ceph ceph name=cephfs,secretfile=/etc/ceph/secret,noatime,nofail 0 0
or
[root@osd003 ~]# mount -t ceph mon01,mon02,mon03:/ /mnt/ceph -o name=admin,secretfile=/etc/ceph/secret,noatime,nofail
mount error 22 = Invalid argument

Without nofail the mount succeeds.

I am running centos7.4 3.10.0-693.17.1.el7. ceph cluster running 12.2.4


Related issues

Copied to fs - Backport #39231: luminous: kclient: nofail option not supported Resolved
Copied to fs - Backport #39232: nautilus: kclient: nofail option not supported Resolved
Copied to fs - Backport #39233: mimic: kclient: nofail option not supported Resolved

History

#1 Updated by Chengguang Xu about 1 year ago

It seems mount command cannot recognize nofail option, not ceph or ceph kernel client.
What version of util-linux do you use? Can you upgrade util-linux to 2.32 and a test again?

#2 Updated by Kenneth Waegeman about 1 year ago

We are running the latest util-linux of centos 7.5, util-linux-2.23.2-52.el7.x86_64.
If we mount another fs type with mount, nofail works (eg tested with NFS), but not with mount.ceph

#3 Updated by Ilya Dryomov 11 months ago

The issue is that mount.ceph helper doesn't handle nofail, but passes it through to the kernel. nofail is a userspace level option, it shouldn't be making it to the kernel.

mount.ceph.c should be taught to handle nofail: not just skip it, but return success if things like address resolution fail, etc.

#4 Updated by Ilya Dryomov 11 months ago

  • Project changed from Linux kernel client to fs
  • Component(FS) kceph added

#5 Updated by Patrick Donnelly 11 months ago

  • Subject changed from nofail option not supported to kclient: nofail option not supported
  • Assignee set to Zheng Yan
  • Priority changed from Normal to High
  • Target version set to v14.0.0
  • Backport set to mimic,luminous

#6 Updated by Kenneth Waegeman 8 months ago

any update on this?

thanks!

#7 Updated by Patrick Donnelly 6 months ago

  • Target version changed from v14.0.0 to v15.0.0

#8 Updated by Kenneth Waegeman 5 months ago

I've an attempt to a fix here https://github.com/ceph/ceph/pull/26992

#9 Updated by Patrick Donnelly 5 months ago

  • Status changed from New to Pending Backport
  • Assignee changed from Zheng Yan to Kenneth Waegeman
  • Start date deleted (03/07/2018)
  • Backport changed from mimic,luminous to nautilus,mimic,luminous
  • Pull request ID set to 26992

#10 Updated by Kenneth Waegeman 5 months ago

Hi,
Should I do something to backport it?

#11 Updated by Patrick Donnelly 5 months ago

Kenneth Waegeman wrote:

Hi,
Should I do something to backport it?

No that's not necessary.

#12 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #39231: luminous: kclient: nofail option not supported added

#13 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #39232: nautilus: kclient: nofail option not supported added

#14 Updated by Nathan Cutler 5 months ago

  • Copied to Backport #39233: mimic: kclient: nofail option not supported added

#15 Updated by Nathan Cutler about 1 month ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF