Project

General

Profile

Bug #23141

BlueFS reports rotational journals if BDEV_WAL is not set

Added by Greg Farnum almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This came in from two different users on the mailing list (https://www.spinics.net/lists/ceph-users/msg42873.html, https://www.spinics.net/lists/ceph-users/msg42977.html) and is important due to the OSD making different config choices when the journal is rotational. In these cases, by inserting default sleeps on backfill.


Related issues

Copied to bluestore - Backport #23173: luminous: BlueFS reports rotational journals if BDEV_WAL is not set Resolved

History

#1 Updated by Greg Farnum almost 5 years ago

BlueFS::wal_is_rotational() returns true if (!bdev[BDEV_WAL]). Updating this to fall back through BDEV_DB and BDEV_SLOW.

#2 Updated by Greg Farnum almost 5 years ago

  • Status changed from New to Fix Under Review

#3 Updated by Kefu Chai almost 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#4 Updated by Nathan Cutler almost 5 years ago

  • Copied to Backport #23173: luminous: BlueFS reports rotational journals if BDEV_WAL is not set added

#6 Updated by Nathan Cutler over 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF