Project

General

Profile

Bug #22980

The rbd resource agent needs to be executable

Added by Tim Bishop over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

https://github.com/ceph/ceph/pull/20397

Without this the resource fails in Pacemaker with the error:

Feb 11 12:48:30 mypacemakerhost crmd[5154]:    error: Failed to retrieve meta-data for ocf:ceph:rbd
Feb 11 12:48:30 mypacemakerhost crmd[5154]:   notice: Operation p_rbd_myres_monitor_0: insufficient privileges (node=mypacemakerhost, call=228, rc=4, cib-update=60, confirmed=true)

This worked fine in the jewel version of the package, but is broken in the luminous one, presumably because of the build changes.

Please merge this change to master and back to luminous.


Related issues

Duplicates rbd - Bug #22362: cluster resource agent ocf:ceph:rbd - wrong permissions Resolved 12/11/2017

History

#1 Updated by Greg Farnum over 3 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Nathan Cutler

Nathan appears to be working on this; hurray!

#2 Updated by Nathan Cutler over 3 years ago

  • Duplicates Bug #22362: cluster resource agent ocf:ceph:rbd - wrong permissions added

#3 Updated by Nathan Cutler over 3 years ago

  • Status changed from Fix Under Review to Duplicate

#4 Updated by Nathan Cutler over 3 years ago

This is another permutation of #22362 - I reopened that one so all the fixes are in one place.

Also available in: Atom PDF