Project

General

Profile

Bug #22785

ceph-volume does not activate OSD using mount options in ceph.conf

Added by Ben England over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

In ceph-ansible, the user can specify in group_vars/all.yml the var osd_mount_options_xfs , and this will result in seeing the "osd mount options xfs" parameter in ceph.conf, but ceph-volume does not use these options when activating an OSD. I believe this is happening at line 42 in /usr/lib/python2.7/site-packages/ceph_volume/devices/lvm/activate.py .

process.run(['sudo', 'mount', '-v', source, destination])

History

#1 Updated by Alfredo Deza over 2 years ago

  • Assignee set to Alfredo Deza

#2 Updated by Alfredo Deza over 2 years ago

  • Status changed from New to In Progress

#3 Updated by Alfredo Deza over 2 years ago

Ben, looking into this, I find that for bluestore we will never mount anything as bluestore OSDs are using a tmpfs. This would only be a case for filestore OSDs. Is this were you saw this problem only? Or were you expecting these to be followed for bluestore?

#4 Updated by Ben England over 2 years ago

I was specifically talking about filestore OSDs, should have been more explicit about this. Bluestore would never use filesystem mount options since it does not really mount the filesystem to access the OSD data or RocksDB. So why do we care? Filestore will be with us for some time to come and it would be nice to have a way to control XFS options, etc. in case we need to. I don't expect it to be commonly used but there may be situations in which it is necessary. If you don't want to support it in ceph-volume, you could either refer people to ceph-disk (which is going away right?) or deprecate these Filestore options altogether, but this is not a major amount of work is it? Does ceph-volume already parse /etc/ceph/ceph.conf? If so you already have the options to add to the mount command. Similarly you would also have the options to pass to the mkfs.xfs command for "osd mkfs options " parameter documented at: http://docs.ceph.com/docs/master/rados/configuration/osd-config-ref/#file-system-settings

#5 Updated by Alfredo Deza over 2 years ago

Just making sure :)

This is going to be an easy fix, should have it resolved pretty quickly. Thanks for confirming!

#6 Updated by Alfredo Deza over 2 years ago

  • Status changed from In Progress to Fix Under Review

#7 Updated by Alfredo Deza over 2 years ago

  • Status changed from Fix Under Review to Resolved

merged commit 9bc0b8b into master

Also available in: Atom PDF