Project

General

Profile

Bug #22642

can't reuse OSD ID if ID doesn't exist in `ceph osd tree`

Added by Alfredo Deza almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

ceph-volume will skip adding the auth required, the monitor will not know about the OSD and it will end up with the OSD not coming up.

Both these lines (one for filestore the other one for bluestore):

    # allow re-using an id, in case a prepare failed
    osd_id = id_ or prepare_utils.create_id(fsid, json_secrets)

Need to change so that a call to the cluster confirms that the ID is really there so there is no need to recreate it.

`ceph osd tree` can do this, but it seems that the admin keyring is required, which would be a no go for ceph-volume since it can't guarantee that an OSD node will have that around.

The workaround here would be to make create_id check if the id_ is already there, and ask for a new one otherwise.

Failure in OSD logs looks similar to this one line:

2018-01-09 23:00:52.378256 7fc3afa53e00 -1 osd.3 0 init authentication failed: (1) Operation not permitted

Related issues

Copied to ceph-volume - Backport #22923: luminous: can't reuse OSD ID if ID doesn't exist in `ceph osd tree` Resolved

History

#1 Updated by Alfredo Deza almost 5 years ago

  • Description updated (diff)

#2 Updated by Alfredo Deza almost 5 years ago

  • Description updated (diff)

#3 Updated by Sage Weil almost 5 years ago

  • Status changed from New to 12

#5 Updated by Andrew Schoen almost 5 years ago

  • Status changed from 12 to Pending Backport

#6 Updated by Ken Dreyer almost 5 years ago

  • Copied to Backport #22923: luminous: can't reuse OSD ID if ID doesn't exist in `ceph osd tree` added

#7 Updated by Ken Dreyer almost 5 years ago

  • Backport set to luminous

#8 Updated by Andrew Schoen almost 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF