Project

General

Profile

Bug #22608

Missing TrackedOp events "header_read", "throttled", "all_read" and "all_read"

Added by Xuehan Xu almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Recently, when trying to locate some performance bottleneck, we opened the OpTracker. However, we found that events "header_read", "throttled", "all_read" and "all_read" are missing. After reading the source code, we believe that this is because the "tracking_start" method is invoked in create_request after the construction of TrackedOps.

History

#1 Updated by Xuehan Xu almost 5 years ago

I've just submitted a PR: https://github.com/ceph/ceph/pull/19828

#2 Updated by Sage Weil almost 5 years ago

  • Status changed from New to 12

#3 Updated by Yuri Weinstein almost 5 years ago

Xuehan Xu wrote:

I've just submitted a PR: https://github.com/ceph/ceph/pull/19828

merged

#4 Updated by Nathan Cutler almost 5 years ago

  • Status changed from 12 to Resolved

Also available in: Atom PDF