Project

General

Profile

Bug #22527

mgr.x runtime_error in json_spirit on upgrade

Added by Sage Weil almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2017-12-21T00:20:45.577 INFO:tasks.ceph.mgr.x.smithi024.stderr:terminate called after throwing an instance of 'std::runtime_error'
2017-12-21T00:20:45.591 INFO:tasks.ceph.mgr.x.smithi024.stderr:  what():  value type is 1 not 0
2017-12-21T00:20:45.591 INFO:tasks.ceph.mgr.x.smithi024.stderr:*** Caught signal (Aborted) **
2017-12-21T00:20:45.591 INFO:tasks.ceph.mgr.x.smithi024.stderr: in thread 7feb0f469700 thread_name:fn_anonymous
2017-12-21T00:20:45.593 INFO:tasks.ceph.mgr.x.smithi024.stderr: ceph version 12.2.2-39-g88b4534 (88b4534a0fab6f7020874ff8903b2f2eb9d06eb2) luminous (stable)
2017-12-21T00:20:45.594 INFO:tasks.ceph.mgr.x.smithi024.stderr: 1: (()+0x3f40a4) [0x55635edb80a4]
2017-12-21T00:20:45.594 INFO:tasks.ceph.mgr.x.smithi024.stderr: 2: (()+0x11390) [0x7feb1792f390]
2017-12-21T00:20:45.594 INFO:tasks.ceph.mgr.x.smithi024.stderr: 3: (gsignal()+0x38) [0x7feb168bf428]
2017-12-21T00:20:45.594 INFO:tasks.ceph.mgr.x.smithi024.stderr: 4: (abort()+0x16a) [0x7feb168c102a]
2017-12-21T00:20:45.594 INFO:tasks.ceph.mgr.x.smithi024.stderr: 5: (__gnu_cxx::__verbose_terminate_handler()+0x16d) [0x7feb1720284d]
2017-12-21T00:20:45.594 INFO:tasks.ceph.mgr.x.smithi024.stderr: 6: (()+0x8d6b6) [0x7feb172006b6]
2017-12-21T00:20:45.595 INFO:tasks.ceph.mgr.x.smithi024.stderr: 7: (()+0x8d701) [0x7feb17200701]
2017-12-21T00:20:45.595 INFO:tasks.ceph.mgr.x.smithi024.stderr: 8: (()+0x8d919) [0x7feb17200919]
2017-12-21T00:20:45.595 INFO:tasks.ceph.mgr.x.smithi024.stderr: 9: (json_spirit::Value_impl<json_spirit::Config_map<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >::check_type(json_spirit::Value_type) const+0x12d) [0x55635ec9611d]
2017-12-21T00:20:45.595 INFO:tasks.ceph.mgr.x.smithi024.stderr: 10: (json_spirit::Value_impl<json_spirit::Config_map<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > >::get_obj()+0xb) [0x55635ecc607b]
2017-12-21T00:20:45.595 INFO:tasks.ceph.mgr.x.smithi024.stderr: 11: (MetadataUpdate::finish(int)+0x502) [0x55635ecc7592]
2017-12-21T00:20:45.596 INFO:tasks.ceph.mgr.x.smithi024.stderr: 12: (Context::complete(int)+0x9) [0x55635ec6fc39]
2017-12-21T00:20:45.596 INFO:tasks.ceph.mgr.x.smithi024.stderr: 13: (Finisher::finisher_thread_entry()+0x460) [0x55635edf80d0]
2017-12-21T00:20:45.596 INFO:tasks.ceph.mgr.x.smithi024.stderr: 14: (()+0x76ba) [0x7feb179256ba]
2017-12-21T00:20:45.596 INFO:tasks.ceph.mgr.x.smithi024.stderr: 15: (clone()+0x6d) [0x7feb169913dd]
2017-12-21T00:20:45.596 INFO:tasks.ceph.mgr.x.smithi024.stderr:2017-12-21 00:20:45.588061 7feb0f469700 -1 *** Caught signal (Aborted) **
2017-12-21T00:20:45.596 INFO:tasks.ceph.mgr.x.smithi024.stderr: in thread 7feb0f469700 thread_name:fn_anonymous

/a/sage-2017-12-20_22:44:45-rados-wip-sage-testing-2017-12-20-1357-distro-basic-smithi/1986414

Related issues

Related to CephFS - Bug #21393: MDSMonitor: inconsistent role/who usage in command help Resolved 09/14/2017

History

#1 Updated by Kefu Chai almost 5 years ago

/a/kchai-2017-12-23_05:58:55-rados-wip-kefu-testing-2017-12-23-1241-distro-basic-mira/1996509

#3 Updated by Kefu Chai almost 5 years ago

  • Project changed from mgr to CephFS
  • Component(FS) MDSMonitor added

#4 Updated by Kefu Chai almost 5 years ago

  • Project changed from CephFS to mgr
  • Assignee set to Patrick Donnelly

hey Patrick, could you take a look?

#5 Updated by Patrick Donnelly almost 5 years ago

I'm inclined to revert [1] as it's not worth the trouble it's caused. There isn't a clean way to make the upgrade testing work and changing the JSON format broke the mgr.

[1] https://github.com/ceph/ceph/pull/19369

#6 Updated by John Spray almost 5 years ago

+1 -- I'd revert that. The original format with the dicts is kind of ugly, but I don't think there's a strong enough need to spend effort managing the transition to lists (at least, unless someone else cares enough to do the whole job including dealing with upgrades from the mgr side).

#7 Updated by Zheng Yan almost 5 years ago

+1 for revert

#8 Updated by Patrick Donnelly almost 5 years ago

  • Status changed from 12 to Resolved

Fixed by f6e1a797d45d7d646835bad8e258908407b2695b.

#9 Updated by Kefu Chai almost 5 years ago

http://pulpito.ceph.com/kchai-2018-01-08_13:52:40-rados-wip-kefu-testing-2018-01-08-1914-distro-basic-mira/2042789/

i still have this issue in a upgrade test. but the branch being tested does include the revert change. weird enough..

#10 Updated by Patrick Donnelly almost 5 years ago

  • Related to Bug #21393: MDSMonitor: inconsistent role/who usage in command help added

#11 Updated by Patrick Donnelly almost 5 years ago

Kefu Chai wrote:

http://pulpito.ceph.com/kchai-2018-01-08_13:52:40-rados-wip-kefu-testing-2018-01-08-1914-distro-basic-mira/2042789/

i still have this issue in a upgrade test. but the branch being tested does include the revert change. weird enough..

Caused by the fix to #21393

#12 Updated by Patrick Donnelly almost 5 years ago

  • Status changed from Resolved to Fix Under Review

Patrick Donnelly wrote:

Kefu Chai wrote:

http://pulpito.ceph.com/kchai-2018-01-08_13:52:40-rados-wip-kefu-testing-2018-01-08-1914-distro-basic-mira/2042789/

i still have this issue in a upgrade test. but the branch being tested does include the revert change. weird enough..

Caused by the fix to #21393

https://github.com/ceph/ceph/pull/19926

#13 Updated by Sage Weil almost 5 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF