Project

General

Profile

Bug #22441

mgr prometheus module failed on 12.2.2

Added by Sergey Kharlamov almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
Start date:
12/14/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/luminous-x
Pull request ID:

Description

After upgrade 12.2.1 -> 12.2.2 prometheus module is not working.

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/cherrypy/_cprequest.py", line 670, in respond
    response.body = self.handler()
  File "/usr/lib/python2.7/dist-packages/cherrypy/lib/encoding.py", line 217, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/cherrypy/_cpdispatch.py", line 61, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/usr/lib/ceph/mgr/prometheus/module.py", line 386, in metrics
    metrics = global_instance().collect()
  File "/usr/lib/ceph/mgr/prometheus/module.py", line 324, in collect
    self.get_pg_status()
  File "/usr/lib/ceph/mgr/prometheus/module.py", line 266, in get_pg_status
    self.metrics[path].set(value)
KeyError: 'pg_deep'

Related issues

Duplicates mgr - Bug #22116: prometheus module 500 if 'deep' in pg states Resolved 11/13/2017

History

#1 Updated by Nathan Cutler almost 2 years ago

  • Project changed from Ceph to mgr
  • Priority changed from Normal to Urgent

Raising priority because this would be a regression, if confirmed.

#2 Updated by Nathan Cutler almost 2 years ago

  • Status changed from New to Duplicate

#3 Updated by Nathan Cutler almost 2 years ago

  • Duplicates Bug #22116: prometheus module 500 if 'deep' in pg states added

Also available in: Atom PDF