Project

General

Profile

Bug #22363

Watchers are lost on active RBD image with running client

Added by Wido den Hollander almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Target version:
-
Start date:
12/11/2017
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

See: http://lists.ceph.com/pipermail/ceph-users-ceph.com/2017-November/022850.html

The issue is observed on a Jewel cluster running with client 10.2.7 and cluster 10.2.10

Without a known reason watchers are lost on some images and this causes corruption/RO inside the running VM.

Restarting or a live-migrate of the Instance to a different node brings the Watcher back.

Creating this ticket here so it's tracked.

History

#1 Updated by Greg Farnum almost 2 years ago

  • Project changed from Ceph to rbd
  • Category deleted (librbd)

#2 Updated by Jason Dillaman almost 2 years ago

  • Status changed from New to Need More Info

Need a gcore dump of the affected process or aggressive logging enabled (debug ms = 1, debug objecter = 20).

#3 Updated by Jason Dillaman over 1 year ago

  • Status changed from Need More Info to Resolved

I believe this was resolved by #19957

Also available in: Atom PDF