Project

General

Profile

Bug #22311

Luminous 12.2.2: some of rpm packages is not signed.

Added by Konstantin Shalygin over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
common
Target version:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/client-upgrade
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When I try to update qemu host for new librbd:

======================================================================================================================================================
 Package                           Arch                           Version                                   Repository                           Size
======================================================================================================================================================
Updating:
 librados2                         x86_64                         2:12.2.2-0.el7                            ceph_stable                         2.8 M
 librbd1                           x86_64                         2:12.2.2-0.el7                            ceph_stable                         1.1 M

Transaction Summary
======================================================================================================================================================
Upgrade  2 Packages

Total download size: 3.9 M
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
Package librbd1-12.2.2-0.el7.x86_64.rpm is not signed
(1/2): librbd1-12.2.2-0.el7.x86_64.rpm                                                                                         | 1.1 MB  00:00:00     
(2/2): librados2-12.2.2-0.el7.x86_64.rpm                                                                                       | 2.8 MB  00:00:00     
------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                  23 MB/s | 3.9 MB  00:00:00     

Package librados2-12.2.2-0.el7.x86_64.rpm is not signed

History

#1 Updated by Greg Farnum over 3 years ago

  • Assignee set to Alfredo Deza

I know some packages got signed/fixed, not sure if these ones are still wrong...

#2 Updated by Alfredo Deza over 3 years ago

  • Status changed from New to Resolved

Already fixed.

$ sudo rpm -qi librados2
Name        : librados2
Epoch       : 2
Version     : 12.2.2
Release     : 0.el7
Architecture: x86_64
Install Date: Mon 04 Dec 2017 02:44:29 PM UTC
Group       : Unspecified
Size        : 11536680
License     : LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and BSD-3-Clause and MIT
Signature   : RSA/SHA256, Mon 04 Dec 2017 02:34:19 PM UTC, Key ID e84ac2c0460f3994
Source RPM  : ceph-12.2.2-0.el7.src.rpm
Build Date  : Thu 30 Nov 2017 04:20:02 PM UTC
Build Host  : slave-centos07
Relocations : (not relocatable)
URL         : http://ceph.com/
Summary     : RADOS distributed object store client library
Description :
RADOS is a reliable, autonomic distributed object storage cluster
developed as part of the Ceph distributed storage system. This is a
shared library allowing applications to access the distributed object
store using a simple file-like interface.

#3 Updated by Konstantin Shalygin over 3 years ago

Now yum happy, thanks.

Also available in: Atom PDF