Project

General

Profile

Bug #22116

prometheus module 500 if 'deep' in pg states

Added by John Spray almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
prometheus module
Target version:
-
Start date:
11/13/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description


Related issues

Duplicated by mgr - Bug #22337: Prometheus exporter in the MGR daemon crashes when PGs are in recovery_wait state Duplicate 12/06/2017
Duplicated by mgr - Bug #22441: mgr prometheus module failed on 12.2.2 Duplicate 12/14/2017
Duplicated by mgr - Bug #22474: prometheus plugin breaks if an osd is out Duplicate
Duplicated by mgr - Bug #22612: ceph-mgr's prometheus module crashes when osd is out Duplicate 01/08/2018
Duplicated by mgr - Bug #22947: Prometheus exporter module fails due to incorrect PG_STATES Duplicate 02/07/2018
Copied to mgr - Backport #22238: luminous: prometheus module 500 if 'deep' in pg states Resolved

History

#2 Updated by John Spray almost 2 years ago

When backporting, let's do both PRs together.

#3 Updated by Nathan Cutler almost 2 years ago

  • Status changed from New to Testing

The first PR is still open.

#4 Updated by Kefu Chai almost 2 years ago

  • Status changed from Testing to Pending Backport

#5 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #22238: luminous: prometheus module 500 if 'deep' in pg states added

#6 Updated by John Spray over 1 year ago

  • Duplicated by Bug #22337: Prometheus exporter in the MGR daemon crashes when PGs are in recovery_wait state added

#7 Updated by Nathan Cutler over 1 year ago

  • Duplicated by Bug #22441: mgr prometheus module failed on 12.2.2 added

#8 Updated by John Spray over 1 year ago

  • Duplicated by Bug #22474: prometheus plugin breaks if an osd is out added

#9 Updated by Nathan Cutler over 1 year ago

  • Duplicated by Bug #22612: ceph-mgr's prometheus module crashes when osd is out added

#10 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

#11 Updated by John Spray over 1 year ago

  • Related to Bug #22947: Prometheus exporter module fails due to incorrect PG_STATES added

#12 Updated by John Spray over 1 year ago

  • Related to deleted (Bug #22947: Prometheus exporter module fails due to incorrect PG_STATES)

#13 Updated by John Spray over 1 year ago

  • Duplicated by Bug #22947: Prometheus exporter module fails due to incorrect PG_STATES added

Also available in: Atom PDF