Project

General

Profile

Bug #22063

"RadosModel.h: 1703: FAILED assert(!version || comp->get_version64() == version)" inrados-jewel-distro-basic-smithi

Added by Yuri Weinstein over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
Correctness/Safety
Target version:
-
Start date:
11/07/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Component(RADOS):
Pull request ID:

Description

Run: http://pulpito.ceph.com/teuthology-2017-11-04_02:00:03-rados-jewel-distro-basic-smithi/
Jobs: '1809487', '1809470'
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2017-11-04_02:00:03-rados-jewel-distro-basic-smithi/1809487/teuthology.log

2017-11-07T12:29:17.377 INFO:tasks.rados.rados.0.smithi010.stdout:1769:  finishing write tid 1 to smithi01019529-530
2017-11-07T12:29:17.377 INFO:tasks.rados.rados.0.smithi010.stdout:1767:  finishing copy_from racing read to smithi01019529-12
2017-11-07T12:29:17.377 INFO:tasks.rados.rados.0.smithi010.stdout:1763:  finishing copy_from to smithi01019529-185 oooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo
2017-11-07T12:29:17.377 INFO:tasks.rados.rados.0.smithi010.stderr:./test/osd/RadosModel.h: In function 'virtual void CopyFromOp::_finish(TestOp::CallbackInfo*)' thread 7f0cb6ffd700 time 2017-11-07 12:29:17.337229
2017-11-07T12:29:17.378 INFO:tasks.rados.rados.0.smithi010.stderr:./test/osd/RadosModel.h: 1703: FAILED assert(!version || comp->get_version64() == version)
2017-11-07T12:29:17.385 INFO:tasks.rados.rados.0.smithi010.stderr: ceph version 10.2.10-42-g917cad9 (917cad9fd037118c2993f7b56eb1305727d007b8)
2017-11-07T12:29:17.385 INFO:tasks.rados.rados.0.smithi010.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x85) [0x55709ed64385]
2017-11-07T12:29:17.385 INFO:tasks.rados.rados.0.smithi010.stderr: 2: (CopyFromOp::_finish(TestOp::CallbackInfo*)+0x4fb) [0x55709ed47d5b]
2017-11-07T12:29:17.385 INFO:tasks.rados.rados.0.smithi010.stderr: 3: (write_callback(void*, void*)+0x19) [0x55709ed5b1a9]
2017-11-07T12:29:17.385 INFO:tasks.rados.rados.0.smithi010.stderr: 4: (()+0x9ef9d) [0x7f0cc46b1f9d]
2017-11-07T12:29:17.385 INFO:tasks.rados.rados.0.smithi010.stderr: 5: (()+0x87349) [0x7f0cc469a349]
2017-11-07T12:29:17.386 INFO:tasks.rados.rados.0.smithi010.stderr: 6: (()+0x176016) [0x7f0cc4789016]
2017-11-07T12:29:17.386 INFO:tasks.rados.rados.0.smithi010.stderr: 7: (()+0x7e25) [0x7f0cc3a7be25]
2017-11-07T12:29:17.386 INFO:tasks.rados.rados.0.smithi010.stderr: 8: (clone()+0x6d) [0x7f0cc296334d]
2017-11-07T12:29:17.386 INFO:tasks.rados.rados.0.smithi010.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

Related issues

Related to RADOS - Bug #22064: "RadosModel.h: 865: FAILED assert(0)" in rados-jewel-distro-basic-smithi Duplicate 11/07/2017
Related to RADOS - Bug #23598: hammer->jewel: ceph_test_rados crashes during radosbench task in jewel rados upgrade test Duplicate 04/09/2018
Duplicates RADOS - Bug #22123: osd: objecter sends out of sync with pg epochs for proxied ops Resolved 11/14/2017

History

#1 Updated by Yuri Weinstein over 1 year ago

could be related or dupe of http://tracker.ceph.com/issues/22064

#2 Updated by Greg Farnum over 1 year ago

  • Project changed from Ceph to RADOS
  • Category set to Correctness/Safety

#5 Updated by David Zafman over 1 year ago

  • Related to Bug #22064: "RadosModel.h: 865: FAILED assert(0)" in rados-jewel-distro-basic-smithi added

#6 Updated by Nathan Cutler over 1 year ago

Another jewel run with this bug:

The following failure from the same run is #22064

2018-02-07T09:08:09.182 INFO:tasks.rados.rados.0.smithi112.stderr:./test/osd/RadosModel.h: In function 'virtual void WriteOp::_finish(TestOp::CallbackInfo*)' thread 7fce9affd700 time 2018-02-07 09:08:09.190775
2018-02-07T09:08:09.182 INFO:tasks.rados.rados.0.smithi112.stderr:./test/osd/RadosModel.h: 865: FAILED assert(0)
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: ceph version 10.2.10-238-ga95e2c4 (a95e2c4958b256d75ea1c732c2f2cce45f024081)
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x80) [0x56286cf74f40]
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 2: (WriteOp::_finish(TestOp::CallbackInfo*)+0x562) [0x56286cf53ed2]
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 3: (write_callback(void*, void*)+0x19) [0x56286cf6c7a9]
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 4: (()+0x971fd) [0x7fceac4131fd]
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 5: (()+0x81dc9) [0x7fceac3fddc9]
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 6: (()+0x17213e) [0x7fceac4ee13e]
2018-02-07T09:08:09.183 INFO:tasks.rados.rados.0.smithi112.stderr: 7: (()+0x76ba) [0x7fceabd3c6ba]
2018-02-07T09:08:09.184 INFO:tasks.rados.rados.0.smithi112.stderr: 8: (clone()+0x6d) [0x7fceaa6263dd]
2018-02-07T09:08:09.184 INFO:tasks.rados.rados.0.smithi112.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

Full log: http://qa-proxy.ceph.com/teuthology/smithfarm-2018-02-06_21:07:15-rados-wip-jewel-backports-distro-basic-smithi/2160668/teuthology.log (description: rados/thrash/{0-size-min-size-overrides/2-size-1-min-size.yaml 1-pg-log-overrides/normal_pg_log.yaml clusters/{fixed-2.yaml openstack.yaml} hobj-sort.yaml msgr-failures/fastclose.yaml msgr/async.yaml objectstore/filestore-xfs.yaml rados.yaml thrashers/default.yaml workloads/small-objects.yaml})

#7 Updated by David Zafman over 1 year ago

  • Duplicates Bug #22123: osd: objecter sends out of sync with pg epochs for proxied ops added

#8 Updated by David Zafman over 1 year ago

  • Status changed from New to Duplicate

#9 Updated by Nathan Cutler about 1 year ago

  • Related to Bug #23598: hammer->jewel: ceph_test_rados crashes during radosbench task in jewel rados upgrade test added

Also available in: Atom PDF