Project

General

Profile

Bug #21993

"ceph osd create" is not idempotent

Added by Kefu Chai almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Tests
Target version:
-
Start date:
11/01/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Monitor
Pull request ID:

Description

it is not without the "id" and "uuid" parameter.

but since it's considered deprecated. this tick is just for the record, in hope that people can reach here by searching using the keyword.

/a/kchai-2017-10-31_13:59:11-rados-wip-kefu-testing-2017-10-31-1919-distro-basic-mira/1796062 failed because the ceph cli injected a socket failure while reading from monitor, so the monitor received a RESET from its client when sending the reply of "ceph osd create" command. that's why the client sends 3 "ceph osd create" commands in a row with "CEPH_CLI_TEST_DUP_COMMAND" set.

that's why the returned osd id is 6 not 5.

probably we should always pass the uuid parameter in the test to avoid this problem.


Related issues

Copied to RADOS - Backport #22019: luminous: "ceph osd create" is not idempotent Resolved

History

#1 Updated by Kefu Chai almost 2 years ago

  • Status changed from New to Need Review
  • Assignee set to Kefu Chai
  • Component(RADOS) Monitor added

#2 Updated by Kefu Chai almost 2 years ago

  • Status changed from Need Review to Pending Backport
  • Backport set to luminous

add backport=luminous, because i think it could help to silence some false alarms in rados qa run with luminous branch also.

#3 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #22019: luminous: "ceph osd create" is not idempotent added

#4 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF