Project

General

Profile

Bug #21982

osdc/Objecter: objecter op_send_bytes perf counter always 0

Added by Honggang Yang almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Objecter
Target version:
-
Start date:
10/31/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

# ./bin/ceph daemon /tmp/ceph-asok.mMaOCs/client.rgw.32135.asok --conf ceph.conf perf dump| grep op_send
*** DEVELOPER MODE: setting PATH, PYTHONPATH and LD_LIBRARY_PATH ***
        "op_send": 38426,
        "op_send_bytes": 0,
        "poolop_send": 0,


Related issues

Copied to Ceph - Backport #22189: luminous: osdc/Objecter: objecter op_send_bytes perf counter always 0 Resolved

History

#1 Updated by jianpeng ma almost 2 years ago

This because at this time, MOSDOP don't encode_payload. So m->get_data.length() = 0.
https://github.com/ceph/ceph/pull/18810 can fix this .

#2 Updated by Kefu Chai almost 2 years ago

  • Status changed from New to Pending Backport
  • Backport set to luminous

#3 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #22189: luminous: osdc/Objecter: objecter op_send_bytes perf counter always 0 added

#4 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF