Project

General

Profile

Bug #21759

Assertion in EImportStart::replay should be a damaged()

Added by John Spray over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
fsck/damage handling
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

This is one of a number of assertions that still linger in journal.cc, but since it's been seen in the wild ("[ceph-users] assertion error trying to start mds server"), let's at least make an effort to handle it gracefully.


Related issues

Copied to CephFS - Backport #21870: luminous: Assertion in EImportStart::replay should be a damaged() Resolved

History

#1 Updated by John Spray over 6 years ago

  • Status changed from In Progress to Fix Under Review
  • Backport set to luminous

#2 Updated by Patrick Donnelly over 6 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler over 6 years ago

  • Copied to Backport #21870: luminous: Assertion in EImportStart::replay should be a damaged() added

#4 Updated by Patrick Donnelly about 6 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF