Project

General

Profile

Bug #21735

multisite: data sync status advances despite failure in RGWListBucketIndexesCR

Added by Casey Bodley about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

When data sync status is StateBuildingFullSyncMaps, RGWDataSyncCR calls RGWListBucketIndexesCR to build a full sync map.

If the GET request to list /admin/metadata/bucket.instance fails, we log the error "ERROR: failed to fetch metadata for section bucket.index" but RGWDataSyncCR still advances the sync status to StateSync and attempts to run full sync.

The attempt to run full sync get stuck in a retry loop because it fails to read the full sync map.


Related issues

Copied to rgw - Backport #21938: luminous: multisite: data sync status advances despite failure in RGWListBucketIndexesCR Resolved
Copied to rgw - Backport #21951: jewel: multisite: data sync status advances despite failure in RGWListBucketIndexesCR Resolved

History

#1 Updated by Casey Bodley about 3 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Matt Benjamin almost 3 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Anonymous almost 3 years ago

  • Copied to Backport #21938: luminous: multisite: data sync status advances despite failure in RGWListBucketIndexesCR added

#4 Updated by Nathan Cutler almost 3 years ago

  • Copied to Backport #21951: jewel: multisite: data sync status advances despite failure in RGWListBucketIndexesCR added

#5 Updated by Nathan Cutler over 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF