Project

General

Profile

Bug #21734

mount client shows total capacity of cluster but not of a pool

Added by Petr Malkov over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature:

Description

SERVER:

ceph df
GLOBAL:
SIZE AVAIL RAW USED %RAW USED
44637G 44519G 117G 0.26
POOLS:
NAME ID USED %USED MAX AVAIL OBJECTS
cephfs_data 9 1492M 0 14073G 389

CLIENT:

mount -t ceph ceph-1:6789:/ /cephfs -o name=admin,secretfile=admin.key

mount client shows total capacity of cluster but not of a pool

df -h
Filesystem Size Used Avail Use% Mounted on
192.168.149.21:6789:/ 44T 118G 44T 1% /cephfs

Related issues

Duplicates CephFS - Feature #19109: Use data pool's 'df' for statfs instead of global stats, if there is only one data pool Resolved 02/28/2017

History

#1 Updated by Patrick Donnelly over 3 years ago

  • Duplicates Feature #19109: Use data pool's 'df' for statfs instead of global stats, if there is only one data pool added

#2 Updated by Patrick Donnelly over 3 years ago

  • Status changed from New to Duplicate

#3 Updated by John Spray about 3 years ago

  • Project changed from Ceph to CephFS
  • Category deleted (129)

(Just moving this closed ticket because I'm deleting the bogus "cephfs" category in the toplevel Ceph project)

Also available in: Atom PDF