Project

General

Profile

Bug #21577

ceph-monstore-tool --readable mode doesn't understand FSMap, MgrMap

Added by John Spray about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Annoying for anyone wanting to inspect these. I never updated it because I don't think I knew it existed :-)


Related issues

Copied to RADOS - Backport #21636: luminous: ceph-monstore-tool --readable mode doesn't understand FSMap, MgrMap Resolved

History

#1 Updated by John Spray about 5 years ago

  • Status changed from In Progress to Fix Under Review
  • Backport set to luminous

https://github.com/ceph/ceph/pull/18005

Marking for backport -- I consider this a bugfix because the mdsmap dumping was completely nonfunctional since we switched to fsmap.

#2 Updated by Kefu Chai about 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 5 years ago

  • Copied to Backport #21636: luminous: ceph-monstore-tool --readable mode doesn't understand FSMap, MgrMap added

#4 Updated by Nathan Cutler almost 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF