Project

General

Profile

Bug #21561

[rbd-mirror] primary image should register in remote, non-primary image's journal

Added by Jason Dillaman about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Jason Dillaman
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Due to a change during luminous development, the local primary will not register w/ the remote non-primary. After an orderly failover, it's possible for remote journal entries to be purged before the local image can replay them.


Related issues

Copied to rbd - Backport #21793: luminous: [rbd-mirror] primary image should register in remote, non-primary image's journal Resolved

History

#1 Updated by Jason Dillaman about 5 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Mykola Golub about 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 5 years ago

  • Copied to Backport #21793: luminous: [rbd-mirror] primary image should register in remote, non-primary image's journal added

#4 Updated by Jason Dillaman almost 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF