Project

General

Profile

Bug #21558

rbd ls -l crashes with SIGABRT

Added by Jérôme Poulin about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Jason Dillaman
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous,jewel
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

We've been upgrading our cluster from Hammer to Jewel, the upgrade has completed, sortbitwise and require_jewel_osds are set, clients (libvirt/qemu) are connected and fully working.

Now, rbd ls -l crashes for 1 of our 2 pools. RBD crash log with debugging symbols attached.

client.admin.16509.log View (144 KB) Jérôme Poulin, 09/26/2017 03:15 PM

gdb-session.txt View (155 KB) Jérôme Poulin, 09/26/2017 03:16 PM


Related issues

Copied to rbd - Backport #21641: luminous: rbd ls -l crashes with SIGABRT Resolved
Copied to rbd - Backport #21642: jewel: rbd ls -l crashes with SIGABRT Resolved

History

#1 Updated by Jérôme Poulin about 5 years ago

After trying rbd from Hammer and Infernalis, both are able to use rbd ls -l on the problematic pool on the remote cluster, however, rbd from Jewel and Luminous aren't working.

#2 Updated by Jérôme Poulin about 5 years ago

I'd like to update my issue to change the release to Jewel.

Our cluster is at version 10.2.9 (2ee413f77150c0f375ff6f10edd6c8f9c7d060d0) and the tools I'm using are rbd from either version 10.2.9 or version 12.2.0.

#3 Updated by Brad Hubbard about 5 years ago

  • Category set to librbd

#4 Updated by Brad Hubbard about 5 years ago

  • Project changed from Ceph to rbd
  • Category deleted (librbd)

#5 Updated by Jason Dillaman about 5 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman
  • Backport set to luminous,jewel

#6 Updated by Jason Dillaman about 5 years ago

  • Status changed from In Progress to Fix Under Review

#7 Updated by Jérôme Poulin about 5 years ago

After testing RBD from this branch/PR on our Jewel cluster, the problem has been resolved and ls -l is working properly.

#8 Updated by Mykola Golub about 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#9 Updated by Nathan Cutler about 5 years ago

  • Copied to Backport #21641: luminous: rbd ls -l crashes with SIGABRT added

#10 Updated by Nathan Cutler about 5 years ago

#11 Updated by Nathan Cutler almost 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF