Project

General

Profile

Bug #21554

"Accept-ranges" is missed in the Response header of swift API returned by rgw

Added by Anonymous about 5 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

When run OpenStack object storage API tempest test with Ceph rgw, many test cases are failed because the missing of "Accept-ranges" in the Response header of swift API. For example:

Traceback (most recent call last):
File "/opt/stack/tempest/tempest/api/object_storage/test_account_services.py", line 210, in test_list_containers_with_marker_and_end_marker
self.assertHeaders(resp, 'Account', 'GET')
File "/opt/stack/tempest/tempest/api/object_storage/base.py", line 141, in assertHeaders
target, method, self.policies))
File "/usr/local/lib/python2.7/dist-packages/testtools/testcase.py", line 498, in assertThat
raise mismatch_error
testtools.matchers._impl.MismatchError: accept-ranges header does not exist

The issue can be reproduced with Jewel 10.2.9.

History

#1 Updated by Anonymous about 5 years ago

I'm working on the issue.

#2 Updated by Kefu Chai about 5 years ago

  • Status changed from New to Fix Under Review

#3 Updated by John Spray almost 5 years ago

  • Project changed from Ceph to rgw
  • Category deleted (22)

#4 Updated by Casey Bodley about 1 year ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF