Project

General

Profile

Bug #21538

upmap does not respect osd reweights

Added by Theofilos Mouratidis almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSDMap
Target version:
-
Start date:
09/25/2017
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

upmap currently ignores reweighted osds. In other words, out osds, or those with some fractional reweight, get items upmapped to them, which is counter productive when trying to balance OSDs.
In particular, out OSDs will continually get PGs upmapped to them since they have 0 PGs by design.

To demonstrate we added a --mark-out option to osdmaptool, add a new upmap-out test, and fix the problem in OSDMap::calc_pg_upmaps.

Bug and fix here: https://github.com/ceph/ceph/pull/17944


Related issues

Copied to Ceph - Backport #21643: luminous: upmap does not respect osd reweights Resolved

History

#1 Updated by Sage Weil almost 2 years ago

  • Status changed from New to Pending Backport

#2 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #21643: luminous: upmap does not respect osd reweights added

#3 Updated by Kefu Chai almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF