Project

General

Profile

Bug #21534

Incomplete/missing get_store_prefixes implementations in OSDMonitor/MDSMonitor

Added by John Spray about 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Based on comments from https://github.com/ceph/ceph/pull/17929#issuecomment-331768992 -- it looks like we should have been updating get_store_prefixes in order for newly-joined mons to work properly, but we weren't.


Related issues

Copied to Ceph - Backport #21645: luminous: Incomplete/missing get_store_prefixes implementations in OSDMonitor/MDSMonitor Resolved

History

#1 Updated by John Spray about 3 years ago

  • Status changed from In Progress to Fix Under Review

#2 Updated by Kefu Chai about 3 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 3 years ago

  • Copied to Backport #21645: luminous: Incomplete/missing get_store_prefixes implementations in OSDMonitor/MDSMonitor added

#4 Updated by Nathan Cutler almost 3 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF