Project

General

Profile

Bug #21417

buffer_anon leak during deep scrub (on otherwise idle osd)

Added by Sage Weil about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

observed gobs of ram (11gb rss) and most of it buffer_anon (~8gb) on a basically idle cluster with replication, ec, and cache tiering. 12.2.0


Related issues

Copied to RADOS - Backport #21650: luminous: buffer_anon leak during deep scrub (on otherwise idle osd) Resolved

History

#1 Updated by Sage Weil about 5 years ago

  • Subject changed from buffer_anon leak on mostly-idle osd to buffer_anon leak during deep scrub (on otherwise idle osd)

definitely happens from an ec pool.

#2 Updated by Sage Weil about 5 years ago

  • Priority changed from Urgent to Immediate

#3 Updated by Sage Weil about 5 years ago

  • Status changed from Need More Info to Fix Under Review
  • Backport set to luminous

#4 Updated by Sage Weil about 5 years ago

ok, the problem is that as scrub (or whatever) happens, the bluestore cache is populated, but the attrs weren't in the right mempool, which mean we bloated the overall process footprint.

#5 Updated by Sage Weil about 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#6 Updated by Nathan Cutler about 5 years ago

  • Copied to Backport #21650: luminous: buffer_anon leak during deep scrub (on otherwise idle osd) added

#7 Updated by Sage Weil about 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF