Project

General

Profile

Bug #21352

librados version should bump major number when ABI changes

Added by Dan van der Ster about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
librados
Target version:
-
Start date:
09/11/2017
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Our dev team noticed that the librados2 version didn't bump even though luminous changed the ABI. We have binaries compiled against kraken which accepted to run with the librados2 from luminous, which then leads to a segfault.

Should we instead do librados12, etc. as is common?


Related issues

Duplicates RADOS - Bug #21573: [upgrade] buffer::list ABI broken in luminous release Resolved 09/27/2017

History

#1 Updated by Greg Farnum about 2 years ago

We suck at bumping librados versions. It probably needs to go into a pre-release checklist. :/

If you send a patch soon bumping the version I imagine it will go into 12.2.1.

#2 Updated by Dan van der Ster about 2 years ago

Is it that simple? I imagine bumping to librados3 mid-release would cause untold mess downstream. Does this need to be coordinated with distros?

#3 Updated by Josh Durgin about 2 years ago

Dan, which symbols are you seeing changed? Could you get a backtrace of the segfault? There shouldn't have been any incompatible changes with the C abi, though oversights are quite possible. The c++ abi on the other hand is more difficult to preserve, since things like switching compilation mode change the abi.

#4 Updated by Kefu Chai about 2 years ago

  • Status changed from New to Duplicate

Dan, please reopen this ticket if i am wrong.

#5 Updated by Kefu Chai about 2 years ago

  • Duplicates Bug #21573: [upgrade] buffer::list ABI broken in luminous release added

Also available in: Atom PDF