Project

General

Profile

Bug #21203

build_initial_pg_history doesn't update up/acting/etc

Added by Sage Weil almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
08/31/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(RADOS):
Pull request ID:

Description

The loop doesn't update up/acting/etc values, which means the result is incorrect when there are multiple intervals since pg create.

https://github.com/ceph/ceph/pull/15898


Related issues

Copied to RADOS - Backport #21236: luminous: build_initial_pg_history doesn't update up/acting/etc Resolved

History

#2 Updated by Sage Weil almost 2 years ago

  • Status changed from Need Review to Pending Backport

#3 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #21236: luminous: build_initial_pg_history doesn't update up/acting/etc added

#4 Updated by Nathan Cutler over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF