Project

General

Profile

Bug #21199

Support high precision time in rados cli stat output

Added by Abhishek Lekshmanan about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Currently we only have rados cli calling stat, which uses `time_t`, since librados also has an api (`stat2` supporting timespec which has higher precision, it would be useful to have stat with high precision time as well. This is useful for example in inspect radosgw objects which use mtime2 apis.

History

#1 Updated by Abhishek Lekshmanan about 5 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Abhishek Lekshmanan

#2 Updated by xie xingguo about 5 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF