Project

General

Profile

Bug #21191

ceph: tell mds.* results in warning

Added by Patrick Donnelly about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Administration/Usability
Target version:
Start date:
08/30/2017
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
luminous
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
tools
Labels (FS):
Pull request ID:

Description

$ bin/ceph tell mds.\* help
*** DEVELOPER MODE: setting PATH, PYTHONPATH and LD_LIBRARY_PATH ***
2017-08-30 18:12:53.445261 7f022215a700 -1 WARNING: all dangerous and experimental features are enabled.
2017-08-30 18:12:53.457934 7f022215a700 -1 WARNING: all dangerous and experimental features are enabled.
WARN: the service id you provided does not exist. service id should be one of a.
target mds.* doesn't exists, please pass correct target to tell command, such as mon.a/osd.1/mds.a/mgr

Following docs here: http://docs.ceph.com/docs/master/rados/configuration/ceph-conf/#runtime-changes


Related issues

Related to Ceph - Bug #21192: ceph.in: ceph tell gives EINVAL errors Closed 08/30/2017
Copied to fs - Backport #21324: luminous: ceph: tell mds.* results in warning Resolved

History

#1 Updated by Patrick Donnelly about 2 years ago

John believes 9753a0065db8bfb03d86a7185bc636c7aa4c7af7 may be the cause.

#2 Updated by Patrick Donnelly about 2 years ago

  • Description updated (diff)
  • Status changed from New to Need Review

#3 Updated by Patrick Donnelly about 2 years ago

  • Related to Bug #21192: ceph.in: ceph tell gives EINVAL errors added

#4 Updated by Patrick Donnelly about 2 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #21324: luminous: ceph: tell mds.* results in warning added

#6 Updated by Patrick Donnelly almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF