Project

General

Profile

Bug #21159

ceph-mgr spuriously reloading OSD metadata on map changes

Added by John Spray over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Seen while debugging http://tracker.ceph.com/issues/21157

ceph-mgr is issuing "osd metadata" commands for all OSDs each time it sees an OSDMap update (noticeable because with the balancer module we make lots of little map updates). It's apparently not finding the front_addr element on the OSD metadata for some reason.


Related issues

Copied to mgr - Backport #21875: luminous: ceph-mgr spuriously reloading OSD metadata on map changes Resolved

History

#1 Updated by John Spray over 5 years ago

  • Status changed from In Progress to Fix Under Review

Ah, this is already fixed by this PR:

https://github.com/ceph/ceph/pull/16925

#2 Updated by John Spray about 5 years ago

  • Status changed from Fix Under Review to Pending Backport

#3 Updated by Nathan Cutler about 5 years ago

  • Copied to Backport #21875: luminous: ceph-mgr spuriously reloading OSD metadata on map changes added

#4 Updated by Nathan Cutler almost 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF