Project

General

Profile

Bug #21071

qa: test_misc creates metadata pool with dummy object resulting in WRN: POOL_APP_NOT_ENABLED

Added by Patrick Donnelly about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Testing
Target version:
Start date:
08/23/2017
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
fs
Component(FS):
qa-suite
Labels (FS):
Pull request ID:

Description

2017-08-23 02:19:50.363035 mon.a mon.0 172.21.15.141:6789/0 296 : cluster [WRN] Health check failed: application not enabled on 1 pool(s) (POOL_APP_NOT_ENABLED)

From: /ceph/teuthology-archive/pdonnell-2017-08-23_01:47:26-fs-wip-pdonnell-testing-20170822b-distro-basic-smithi/1551815/remote/smithi141/log/ceph.log.gz

Relevant part of test: https://github.com/ceph/ceph/blob/2476469074c1d8647270d23a6c5345bb44c1f460/qa/tasks/cephfs/test_misc.py#L57-L63

Setting the metadata on the pool might not be what we want because the intent of the test is to prevent creating a file system on a pool with objects. If "fs new" fails because the metadata is set on the pool, then we are no longer exercising that failure.


Related issues

Copied to fs - Backport #21449: luminous: qa: test_misc creates metadata pool with dummy object resulting in WRN: POOL_APP_NOT_ENABLED Resolved

History

#1 Updated by Patrick Donnelly about 2 years ago

  • Assignee set to Douglas Fuller

Doug, please take this one.

#2 Updated by Douglas Fuller about 2 years ago

I think we should just whitelist this, then. It's an intentionally pathological case, and this error should not be triggered by anything else in that test.

#3 Updated by Douglas Fuller about 2 years ago

  • Status changed from New to Need Review

#4 Updated by Patrick Donnelly about 2 years ago

  • Status changed from Need Review to Pending Backport

#5 Updated by Nathan Cutler about 2 years ago

  • Copied to Backport #21449: luminous: qa: test_misc creates metadata pool with dummy object resulting in WRN: POOL_APP_NOT_ENABLED added

#6 Updated by Nathan Cutler almost 2 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF