Project

General

Profile

Bug #20890

qa: ceph_test_case wait_for_health is parsing health json wrong

Added by Patrick Donnelly about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
qa
Target version:
Start date:
08/02/2017
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

From: /ceph/teuthology-archive/pdonnell-2017-08-02_17:25:29-fs-wip-pdonnell-testing-20170802-distro-basic-smithi/1474559/teuthology.log

2017-08-02T17:50:04.070 INFO:tasks.cephfs_test_runner:FAILED (errors=1)
2017-08-02T17:50:04.070 INFO:tasks.cephfs_test_runner:
2017-08-02T17:50:04.070 INFO:tasks.cephfs_test_runner:======================================================================
2017-08-02T17:50:04.070 INFO:tasks.cephfs_test_runner:ERROR: test_standby_count_wanted (tasks.cephfs.test_failover.TestFailover)
2017-08-02T17:50:04.070 INFO:tasks.cephfs_test_runner:----------------------------------------------------------------------
2017-08-02T17:50:04.071 INFO:tasks.cephfs_test_runner:Traceback (most recent call last):
2017-08-02T17:50:04.071 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20170802/qa/tasks/cephfs/test_failover.py", line 115, in test_standby_count_wanted
2017-08-02T17:50:04.071 INFO:tasks.cephfs_test_runner:    self.wait_for_health("MDS_INSUFFICIENT_STANDBY", grace*2)
2017-08-02T17:50:04.071 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20170802/qa/tasks/ceph_test_case.py", line 101, in wait_for_health
2017-08-02T17:50:04.072 INFO:tasks.cephfs_test_runner:    self.wait_until_true(seen_health_warning, timeout)
2017-08-02T17:50:04.072 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20170802/qa/tasks/ceph_test_case.py", line 138, in wait_until_true
2017-08-02T17:50:04.072 INFO:tasks.cephfs_test_runner:    if condition():
2017-08-02T17:50:04.072 INFO:tasks.cephfs_test_runner:  File "/home/teuthworker/src/git.ceph.com_ceph-c_wip-pdonnell-testing-20170802/qa/tasks/ceph_test_case.py", line 87, in seen_health_warning
2017-08-02T17:50:04.072 INFO:tasks.cephfs_test_runner:    summary_strings = [s[1]['message'] for s in health['checks'].iteritems()]
2017-08-02T17:50:04.072 INFO:tasks.cephfs_test_runner:KeyError: 'message'

Caused by f8068cd438002743a39300efc1f198684951236c.

History

#1 Updated by John Spray about 2 years ago

  • Status changed from New to Need Review

#2 Updated by Patrick Donnelly about 2 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF