Project

General

Profile

Bug #20839

/root/ceph/src/cls/rbd/cls_rbd_types.h:248:8: warning: ‘<anonymous>.cls::rbd::GroupSnapshotNamespace::group_pool’ may be used uninitialized in this function [-Wmaybe-uninitialized]

Added by Amit Kumar over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
build
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

[ 15%] Building CXX object src/cls/CMakeFiles/cls_rbd.dir/rbd/cls_rbd_types.cc.o
In file included from /root/ceph/src/cls/rbd/cls_rbd_types.cc:5:0:
/root/ceph/src/cls/rbd/cls_rbd_types.h: In member function ‘void cls::rbd::SnapshotNamespaceOnDisk::decode(ceph::buffer::list::iterator&)’:
/root/ceph/src/cls/rbd/cls_rbd_types.h:248:8: warning: ‘<anonymous>.cls::rbd::GroupSnapshotNamespace::group_pool’ may be used uninitialized in this function [-Wmaybe-uninitialized]
struct GroupSnapshotNamespace {
^~~~~~~~~~~~~~~~~~~~
/root/ceph/src/cls/rbd/cls_rbd_types.h:248:8: warning: ‘<anonymous>.cls::rbd::GroupSnapshotNamespace::group_pool’ may be used uninitialized in this function [-Wmaybe-uninitialized]
struct GroupSnapshotNamespace {
^~~~~~~~~~~~~~~~~~~~
/root/ceph/src/cls/rbd/cls_rbd_types.h:248:8: warning: ‘*((void*)(& temp)+8).cls::rbd::GroupSnapshotNamespace::group_pool’ may be used uninitialized in this function [-Wmaybe-uninitialized]
struct GroupSnapshotNamespace {

History

#1 Updated by Amit Kumar over 4 years ago

  • Status changed from New to Closed

Duplicate of #20838

Also available in: Atom PDF