Project

General

Profile

Bug #20789

Compare and write against a clone can result in failure

Added by Jason Dillaman about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
07/27/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
luminous
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

If the block hasn't been copied-up to the clone from the parent, and librbd attempts to perform a "exec copy-up, cmpext, and write" in the same transaction, it will fail since the "cmpext" will fail to read the "copy-up" data.


Related issues

Copied to rbd - Backport #22198: luminous: Compare and write against a clone can result in failure Resolved

History

#1 Updated by Jason Dillaman about 2 years ago

  • Priority changed from Urgent to High

#2 Updated by Jason Dillaman almost 2 years ago

  • Status changed from In Progress to Need Review
  • Backport set to luminous

#3 Updated by Mykola Golub almost 2 years ago

  • Status changed from Need Review to Pending Backport

#4 Updated by Nathan Cutler almost 2 years ago

  • Copied to Backport #22198: luminous: Compare and write against a clone can result in failure added

#5 Updated by Jason Dillaman over 1 year ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF