Project

General

Profile

Bug #2076

ceph fails to build with gcc 4.7

Added by David Nalley over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Fedora has moved to gcc 4.7 for the upcoming Fedora 17 release1.
Currently Ceph fails to build with gcc 4.7.

The following patches permit Ceph to be built with gcc 4.7.

Original author is Tom Callaway <spot at redhat dot com> , and as a contribution to the Fedora Project, they are licensed under LGPLv2.

[1] http://fedoraproject.org/wiki/Features/GCC47

ceph-0.39-comment-out-unused-code-in-dump_pop_map.patch View (940 Bytes) David Nalley, 02/17/2012 08:13 AM

ceph-0.41-compile-fixes.patch View (2.7 KB) David Nalley, 02/17/2012 08:13 AM

History

#1 Updated by Sage Weil over 8 years ago

Committing these, with both of your signed-off-by's.. I assume that's okay?

#2 Updated by David Nalley over 8 years ago

That is indeed fine.

Thanks!

#3 Updated by Sage Weil over 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF