Project

General

Profile

Bug #2037

mon: a crash in the middle of slurping is unrecoverable

Added by Greg Farnum over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Monitor
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

If a monitor comes up and starts slurping, it will start adding incremental maps to its store and update [first|last]_committed on disk. Then it will later retrieve the latest version as a full, stashed map. But if it crashes before retrieving that map, it can't come back up again because initialization will fail, not being able to move from latest_stashed onwards.

History

#1 Updated by Sage Weil over 9 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF