Project

General

Profile

Bug #20307

website request URL without slashes (for folder) returns error

Added by liu hong over 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
jewel kraken
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

eg:
website1 is a bucket and enables website with index.html
blog1 is folder of website1
ceph01 is the hostname of rgw server
The request URL is :
http://website1.ceph01:8081/blog1
it will return 404 not found
it should return the content of index.html in blog1


Related issues

Related to rgw - Bug #23201: s3 website: some s3tests are failing because redirects include index doc suffix Resolved 03/02/2018
Copied to rgw - Backport #20832: jewel: website request URL without slashes (for folder) returns error Rejected
Copied to rgw - Backport #20833: kraken: website request URL without slashes (for folder) returns error Rejected

History

#1 Updated by Greg Farnum over 5 years ago

  • Project changed from Ceph to rgw

#3 Updated by Matt Benjamin over 5 years ago

  • Status changed from New to 7
  • Assignee set to Casey Bodley

#4 Updated by Yuri Weinstein over 5 years ago

Casey Bodley wrote:

https://github.com/ceph/ceph/pull/15703

merged

#5 Updated by Casey Bodley over 5 years ago

  • Status changed from 7 to Pending Backport
  • Backport set to jewel kraken

#6 Updated by Nathan Cutler over 5 years ago

  • Copied to Backport #20832: jewel: website request URL without slashes (for folder) returns error added

#7 Updated by Nathan Cutler over 5 years ago

  • Copied to Backport #20833: kraken: website request URL without slashes (for folder) returns error added

#8 Updated by Casey Bodley almost 5 years ago

  • Related to Bug #23201: s3 website: some s3tests are failing because redirects include index doc suffix added

#9 Updated by Nathan Cutler over 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF