Project

General

Profile

Bug #20282

qa: missing even trivial tests for many commands

Added by Greg Farnum about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
Correctness/Safety
Target version:
-
Start date:
06/13/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

I wrote a trivial script to look for missing commands in tests (https://github.com/ceph/ceph/pull/15675/commits/3aad0f89d527da2d3c995945453276dc7366c954) and it popped up several in the FS:
session kill
session ls
client ls
session evict
client evict
damage ls
mds_compat rm_compat
cpu_profiler


Related issues

Blocks Ceph - Feature #20300: run check_commands.sh as part of make check New 06/14/2017

History

#1 Updated by Greg Farnum about 2 years ago

  • Description updated (diff)

#2 Updated by John Spray about 2 years ago

The damage and client stuff is all exercised in tasks/cephfs/test_* stuff. Are you talking specifically about unit tests?

#3 Updated by Greg Farnum about 2 years ago

  • Blocks Feature #20300: run check_commands.sh as part of make check added

#4 Updated by John Spray about 2 years ago

Greg: can you say which script you're looking to cover these commands in? Things like session kill would be pretty awkward from the basic CLI test scripts, unless they're augmented to mount clients etc, which feels like overkill given that we already have tests elsewhere.

#5 Updated by Greg Farnum about 2 years ago

The script just greps for anything that looks like a COMMMAND and then greps for their existence in qa/ and src/tests. It would not be hard to fool but I'm sort of surprised at the construction if you managed to do so.
(Though now that you mention it I do remember reviewing tests of the session management commands once upon a time.) :)

#6 Updated by John Spray about 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF