Project

General

Profile

Bug #19954

mgr key needs "mon 'allow *'" caps

Added by Tim Serong over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/17/2017
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Prior to https://github.com/ceph/ceph/commit/5906e359bd and https://github.com/ceph/ceph/commit/6625fcd8fd, the mgr key had "mon 'allow *'" caps. Since those commits, it only has "mon 'allow profile mgr'". This means that mgr modules now can't set config keys, so, for example, the new REST API (https://github.com/ceph/ceph/pull/14457) won't actually be able to persist its settings.

Is there a reason the mgr key should have limited mon capabilities, or can we revert those two commits?

History

#1 Updated by John Spray about 2 years ago

  • Status changed from New to Resolved

This is handled with the "profile mgr" mon caps now.

Also available in: Atom PDF