Project

General

Profile

Bug #1995

Turn down non-btrfs warning in FileStore

Added by Greg Farnum over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

WARNING: not btrfs or ext3.  We don't currently support file systems other
            than btrfs and ext3 (data=journal or data=ordered).  Data may be
            lost in the event of a crash.

That's coming out of FileStore.cc. It should probably be turned down (removed?) and certainly needs to be extended to not warn on ext4 or xfs (and maybe warn on ext3, because seriously).

Associated revisions

Revision 36a4ca40 (diff)
Added by Sage Weil over 9 years ago

filestore: remove obsolete fs type check

This isn't a useful check. xfs and ext4 work too.

Fixes: #1995
Signed-off-by: Sage Weil <>

History

#1 Updated by Sage Weil over 9 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF