Project

General

Profile

Bug #19942

"[ FAILED ] TestLibRBD.Metadata" in upgrade:client-upgrade-kraken-distro-basic-smithi

Added by Yuri Weinstein over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/client-upgrade
Pull request ID:
Crash signature:

Description

Run: http://pulpito.ceph.com/teuthology-2017-05-13_05:45:02-upgrade:client-upgrade-kraken-distro-basic-smithi/
Job: 1175561
Logs: http://qa-proxy.ceph.com/teuthology/teuthology-2017-05-13_05:45:02-upgrade:client-upgrade-kraken-distro-basic-smithi/1175561/teuthology.log

2017-05-16T05:56:17.633 INFO:tasks.workunit.client.0.smithi180.stdout:[ RUN      ] TestLibRBD.Metadata
2017-05-16T05:56:17.633 INFO:tasks.workunit.client.0.smithi180.stdout:using new format!
2017-05-16T05:56:17.666 INFO:tasks.workunit.client.0.smithi180.stdout:test/librbd/test_librbd.cc:3676: Failure
2017-05-16T05:56:17.666 INFO:tasks.workunit.client.0.smithi180.stdout:Value of: "value1" 
2017-05-16T05:56:17.667 INFO:tasks.workunit.client.0.smithi180.stdout:Expected: value
2017-05-16T05:56:17.667 INFO:tasks.workunit.client.0.smithi180.stdout:Which is: "value1RNfH0314l[W[uFlvJvk>[nAf1wETN+[\"XDGeTXwB5Pz+si!?ak]<Z{%juG?CQyC*?inrAe4T61^+y^HZL%v&\"xotA0:p*ZyHEg;dMN:b\\ulUU42!8(&8\"s.@#E2,!+TDpl(?:A#v8lMj#\\i:clOba[#d\"2o!=CB-1IKIiM?!;kh;HSS-B$m#^of^#X^=x\"I*JsR3@p1Y[xs%NH0mJ|o*kVgk.G+(FQ1oE`$bR4=.-12XV?G\";6,(krqx:y#_L1OpqPSCboPn\"`FX!lY<\"bAmU4en/gMYvyIgL{,.mZ{l<CD:/{S._tz4(b$5IOm?J8(s64##k{n)>3@J0sXliT#n6$%]Pq{x*&m?7nA$k/*,?ISN<-;%_;st<wQliOdrRS1fCOg/]n8|7jJSwbWXzLL9D}%-Lh!{;1a\\_Jj<8\"8Nk`#dDX<?$fWGeYS1CQ.[_n9@8#ZO$qzoS{SuUm6XUj}:EPJe$U@bEY#ZY\\+]M'L#$|uVk+1Bt.Y9]%{^Y=A{sCWO|_.KdYKeUB>CLLb@Y>V6@Styn7vcWN4U/A}rwKXOluo9AQVwn//1_#*O7}5mMHBZgBL^j&-Xx{n;OG4=SAK2CTaZRuG!=gZ&)'br,nJ'j;?9_SS2q!C6R&m&x5%8{\\;&b|wlkCrW[1m:aBKTBnjrqWujky$hV<k89b&$&wZ`+IzkjE@-3*!'`spNmq6E-\"\\EcbHhY\"KaHEM3il=|u;#U0r%|c9Co:}5zaZe<Z0{$RJ4=6P9-j;az-dvmz<_4;q0yKr5'$2)UY:pnj)zTB\\NN@G<<`zOzk\\s8O*=R:C(r\\ucF}]zA;JmZp+sP%BLm!?'OIA!bc&TBz9gxva93.(k{0`N4%w##7(O_FOA,StKO.2G&s`6!e#yuaG)eA,eW166VdT_9H,fU</Z1lp/Tp*ISOQ8oZ|Fh4YAv/}1T*t,E$eSmUaCHhix9=3(t/K_C$};0|Id(>oJAT|0,]QQF<K\\V[dKj/*-3'EB#m&)+tRIKQYV.*'SCQ2w-sDt$K#\x1" 
2017-05-16T05:56:17.667 INFO:tasks.workunit.client.0.smithi180.stdout:[  FAILED  ] TestLibRBD.Metadata (35 ms)

................

2017-05-16T05:56:28.012 INFO:tasks.workunit.client.0.smithi180.stdout:2: exclusive lock acquired
2017-05-16T05:56:28.050 INFO:tasks.workunit.client.0.smithi180.stdout:2: releasing exclusive lock
2017-05-16T05:56:28.054 INFO:tasks.workunit.client.0.smithi180.stdout:2: exclusive lock released
2017-05-16T05:56:28.081 INFO:tasks.workunit.client.0.smithi180.stdout:[       OK ] TestLibRBD.ExclusiveLock (462 ms)
2017-05-16T05:56:28.750 INFO:tasks.workunit.client.0.smithi180.stderr:Segmentation fault (core dumped)
2017-05-16T05:56:28.751 INFO:tasks.workunit:Stopping ['rbd/test_librbd_api.sh'] on client.0...


Related issues

Related to rbd - Backport #19611: kraken: Issues with C API image metadata retrieval functions Resolved

History

#1 Updated by Jason Dillaman over 3 years ago

  • Project changed from Ceph to rbd

#2 Updated by Mykola Golub over 3 years ago

This tests shows a real bug that was fixed in master #19588 and the test was extended to catch it then. I believe it showed up in this test because the bugfix and test have already been backported to jewel (#19612) but the backport to kraken is still pending (#19611). So it runs the newer test (jewel) that catches the bug using librbd (kraken) that still has the bug.

#3 Updated by Mykola Golub over 3 years ago

  • Related to Backport #19611: kraken: Issues with C API image metadata retrieval functions added

#4 Updated by Mykola Golub over 3 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF